General

What versions of DS/OpenDJ are compatible with IDM/OpenIDM?

Last updated Nov 30, 2018

The purpose of this article is to provide compatibility information between DS/OpenDJ and IDM/OpenIDM versions. This includes connecting to DS/OpenDJ as an external resource (LDAP connector), the embedded DS repositories shipped with later versions of IDM and the supported Java® versions for each combination.


External resources compatibility

You can connect to DS/OpenDJ as an external resource using the LDAP connector (the LDAP connector works with any LDAPv3 compliant servers). The following matrix indicates compatibility between IDM/OpenIDM and DS/OpenDJ when using the LDAP connector:

  DS 6.x DS 5.x OpenDJ 3.x
IDM 6.x Yes Yes Yes
IDM 5.x Yes Yes Yes
OpenIDM 4.x Yes Yes Yes
Note

It is strongly recommended that you always upgrade to the latest maintenance releases for whichever versions of IDM/OpenIDM and DS/OpenDJ you have deployed.

Repositories compatibility

Embedded DS

Embedded DS repositories have been shipped with IDM since IDM 5.5; these repositories are for evaluation purposes only and cannot be used in production. The following embedded DS versions are included with IDM:

IDM versions Embedded DS version
IDM 6.5 DS 6.5
IDM 6 DS 6
IDM 5.5 DS 5.5

External DS

IDM 6 introduced a new feature where an external DS instance can now be used as a supported repository in production environments. The following matrix indicates compatibility between IDM and external DS repositories:

  DS 6.5 DS 6 DS 5.x OpenDJ 3.x
IDM 6.5 Yes -- -- --
IDM 6 -- Yes -- --
IDM 5.x -- -- -- --
OpenIDM 4.x -- -- -- --
Note

It is strongly recommended that you always upgrade to the latest maintenance releases for whichever versions of IDM/OpenIDM and DS/OpenDJ you have deployed.

Java Compatability

Java 11

  • IDM 6.5 and later.
  • DS 6.5 and later.

Java 9

  • DS 6 only.

Java 8

  • IDM 5 and later; OpenIDM 4.x
  • DS 5 and later; OpenDJ 3.x

Java 7

  • IDM 5; OpenIDM 4.x
  • OpenDJ 3.x. Java 7 can be used in DS 5 but support for it is deprecated.

Software and Hardware requirements

IDM/OpenIDM

DS/OpenDJ

See Also

What operating systems are ForgeRock products supported on?

Checking your product versions are supported

FAQ: Upgrading IDM/OpenIDM

FAQ: Installing and configuring IDM/OpenIDM

FAQ: Installing and configuring DS/OpenDJ

Administering and configuring IDM/OpenIDM

Installing and Administering DS/OpenDJ

Related Training

N/A

Related Issue Tracker IDs

N/A



Copyright and TrademarksCopyright © 2018 ForgeRock, all rights reserved.
Loading...