Solutions
Archived

JSON response returned by OpenAM 11.0.0 and 11.0.1 REST API changes attribute case

Last updated Jan 5, 2021

The purpose of this article is to provide assistance if the JSON response returned by OpenAM 11.0.0 and 11.0.1 REST API changes attribute case between the first and subsequent calls.


Archived

This article has been archived and is no longer maintained by ForgeRock.

Symptoms

The first REST call returns a JSON response with the attribute in mixed case (for example, givenName); subsequent REST calls return a JSON response with the attribute all in lower case (for example, givenname). This change in case results in attributes not being found in the data store.

The initial JSON response is the expected one, that is, returning attributes with mixed case which should match the values in your data store configuration.

Recent Changes

Upgraded to OpenAM 11.0.0 or 11.0.1.

Causes

The first call returns attribute names as they are stored in the data store configuration. The result is then cached and during this process, the attributes are converted to all lower case. The cached result is then used for subsequent calls.

Solution

This issue can be resolved by upgrading to OpenAM 11.0.2 or later; you can download this from BackStage.

Alternatively, you could set all the attributes in the data store configuration to lowercase.

See Also

How do I force REST API responses to always use lower case for attribute names in AM (All versions)?

OpenAM 11.0.2 Release Notes › OpenAM Changes & Deprecated Functionality › Important Changes to Existing Functionality

Related Training

N/A

Related Issue Tracker IDs

OPENAM-3159 (Difference in case between results of identity/json/attributes REST API between first and subsequent calls)

OPENAM-4136 (Case sensitivity inconsistent when passing identity attributes as filter on REST interface)


Copyright and Trademarks Copyright © 2021 ForgeRock, all rights reserved.