General
ForgeRock Identity Platform
Does not apply to Identity Cloud

What versions of IG are compatible with AM?

Last updated Oct 18, 2021

The purpose of this article is to provide compatibility information between IG and AM versions. Also included is the supported Java® versions for each combination.


IG and AM compatibility

The following matrix indicates compatibility between AM and IG versions:

  IG 7.x IG 6.5.1, 6.5.2, 6.5.3, 6.5.4 IG 6.5 IG 6, 6.1 IG 5.5.x IG 5
AM 7.x Yes Yes Yes -- -- --
AM 6.5.3, 6.5.4 Yes Yes Yes Yes -- --
AM 6.5.1, 6.5.2 Partly * (most features) Yes Yes Yes -- --
AM 6.5 Partly * (most features) All features except mTLS Yes Yes -- --
AM 6 Partly * (most features) All features except mTLS Yes Yes -- --
AM 5.5.x Partly * (most features) All features except mTLS Yes Yes Yes --
AM 5, 5.1.x Partly * (limited features) Partly * (most features) Partly * (most features) Partly * (most features) Yes Yes

* For details of the specific features supported in these versions, please refer to the relevant IG release notes:

Note

It is strongly recommended that you always upgrade to the latest maintenance releases for whichever versions of AM and IG you have deployed.

Java Compatibility

Java 11

  • AM 6.5 and later.
  • IG 7; IG 6.5 on OpenJDK only.

Java 8

  • AM 5.x and 6.x
  • IG 5.x and 6.x

Java 7

  • AM 5 and 5.1.x
  • IG 5

Software and Hardware requirements

AM

IG

See Also

What operating systems are ForgeRock products supported on?

Checking your product versions are supported

FAQ: Installing AM

FAQ: Upgrading AM

FAQ: Installing and configuring IG

Installing and configuring AM

Installing and configuring IG


Copyright and Trademarks Copyright © 2021 ForgeRock, all rights reserved.