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Email From field errors when entering an email address with a subdomain in IDM 7.1.x

Last updated Jan 11, 2023

The purpose of this article is to provide assistance if you see a "Must be a valid email address" when you enter an email address in the email From field that includes a subdomain (has multiple periods after the @ sign).


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Symptoms

The following error is shown when entering a valid email address in the From field that includes a subdomain or has multiple periods after the @ sign: Must be a valid email address

For example, an email address such as:test@dev.example.com

This issue affects outbound email settings defined in the admin UI: Configure > Email Settings.

Recent Changes

Upgraded to, or installed IDM 7.1.x.

Causes

Validation in the admin UI is incorrectly preventing email addresses that include a subdomain.

Solution

This issue can be resolved by upgrading to IDM 7.2 or later; you can download this from Backstage.

Workaround

You can work around this issue by updating the external.email.json file (located in the /path/to/idm/conf directory) to set the email From field instead. For example:{   "host" : "smtp.gmail.com",     "port" : 587,     "debug" : false,     "auth" : {         "enable" : true,         "username" : "admin",         "password" : "Passw0rd"     },     "from" : "test@dev.example.com",

If you set the From field in this file to include an email address with subdomains, you will still see an error if you open the Email Settings in the admin UI but emails will be sent as expected.

See Also

Outbound email

Related Training

N/A

Related Issue Tracker IDs

OPENIDM-17750 (From field not allowing saving email address with multiple "domains" after the @)


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