Self-service promotion gets stuck in Identity Cloud with a login loop
The purpose of this article is to provide assistance if your self-service promotion gets stuck in ForgeRock Identity Cloud and does not proceed. You will also notice you are repeatedly prompted to sign in even after you have authenticated.
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Symptoms
After requesting a promotion, you are prompted to sign in to the upper environment. Once you have authenticated successfully, you are repeatedly prompted to sign in but nothing happens with the requested promotion. Your environment remains locked during this time.
There are no obvious errors in the logs or failed requests if you examine network traffic using your browser's Developer Tools or capture a HAR file.
Recent Changes
N/A
Causes
Third-party cookies are blocked in your browser or your browser is in incognito mode. This prevents you from authenticating to the upper environment, which stops the promotion from continuing.
The documentation notes these browser requirements: Sign in to the upper environment.
Solution
This issue can be resolved by ensuring your browser has third-party cookies enabled for your tenant domain, you do not have any browser extensions installed that might block cookies and your browser is not in incognito mode.