Solutions

Installing Web policy agent 4.x or 5.x fails with a no ssl/library support error

Last updated Jul 9, 2018

The purpose of this article is to provide assistance if you receive a "no ssl/library support" error when trying to install a Web policy agent.


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Symptoms

An error similar to one of the following is shown when installing the Web policy agent depending on your operating system:

  • On Unix®, Linux® and Solaris® systems:
    init_ssl(): libssl.so is not available 
    init_ssl(): libcrypto.so is not available
    
  • On Microsoft® Windows® systems:
    init_ssl(): ssleay64.dll is not available (error: 126) 
    init_ssl(): libeay64.dll is not available (error: 126)
    
    init_ssl(): ssleay32.dll is not available (error: 126) 
    init_ssl(): libeay32.dll is not available (error: 126)
    

The corresponding install log shows the following error:

2017-08-31 11:27:09 am_agent_login(): error -26 (no ssl/library support) connecting to https://host1.example.com:8443/openam (https://host1.example.com:8443/openam)

Recent Changes

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Causes

The Web policy agent cannot load the SSL libraries. There can be various reasons for this, including:

  • You are trying to install a 32bit version of the policy agent on a 64bit system; the 32bit version of the agentadmin tool cannot open the 64bit SSL libraries.
  • The SSL libraries are not installed.
Note

As of Web policy agents 4, independent NSS/NSPR libraries are no longer included for handling SSL; as of Web policy agent 4.1, the native Schannel for SSL communication is used for Microsoft Windows by default. If your operating system does not include native openssl packages, you must install OpenSSL. See OpenAM Web Policy Agent Release Notes › Before You Install › Important Changes to Existing Functionality (Table 2.2. Supported OpenSSL Versions) for further information on supported versions and Tips and feature insights for Web Policy Agents 4.x for further information on installation.

Solution

The solution depends on the cause as follows:

  • Ensure you are installing the appropriate version of the policy agent; if you have a 64bit operating system, you must install the 64bit policy agent.
  • Ensure either the operating system provides native openssl packages or OpenSSL is installed. If you are using OpenSSL, you can check that the OpenSSL libraries are in the correct location as follows and add them if they are missing:
    • On Linux systems:
      1. Check that the LD_LIBRARY_PATH environment variable is set. For example:
        $ echo $LD_LIBRARY_PATH
        
      2. Check that the OpenSSL libraries (libcrypto.so and libssl.so) are available in the path specified in this environment variable (LD_LIBRARY_PATH). 
    • On Unix and Solaris systems: 
      1. Check that either the LD_LIBRARY_PATH or LD_LIBRARY_PATH_64 environment variable (depending on whether you have a 32bit or 64bit system) is set. For example:
        $ echo $LD_LIBRARY_PATH
        $ echo $LD_LIBRARY_PATH_64
      2. Check that the OpenSSL libraries (libcrypto.so and libssl.so) are available in the path specified in the relevant environment variable (LD_LIBRARY_PATH or LD_LIBRARY_PATH_64). 
    • On Microsoft Windows systems, check that the OpenSSL libraries are in the correct location as follows (depending on whether you have a 32bit or 64bit system):
      • 32bit systems - libeay32.dll and ssleay32.dll files are in the \windows\syswow64  directory.
      • 64bit systems - libeay64.dll and ssleay64.dll files are in the \windows\system32 directory.

See Also

How do I upgrade to Web Policy Agent 4.x from a previous version?

Best practice for installing IIS Web Policy Agents (All versions)

How do I install AM/OpenAM (All versions) with Apache Web Policy Agent on Red Hat Enterprise Linux or CentOS configured with SELinux?

How do I silently remove a Web Policy Agent 4.x or 5.x?

FAQ: SSL/TLS secured connections in AM/OpenAM and Policy Agents

SSL in AM/OpenAM and Policy Agents

Web Agent User Guide

Related Training

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Related Issue Tracker IDs

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