ACTIVE_NOT_READY: Not all modules started error in IDM (All versions)
The purpose of this article is to provide assistance if you encounter errors such as "OpenIDM failure during startup, ACTIVE_NOT_READY: Not all modules started" when starting IDM.
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Symptoms
ACTIVE_NOT_READY: Not all modules started
errors are seen during startup but IDM does start successfully. You will see variations on this error when this happens, for example:
- OpenIDM failure during startup:SEVERE: OpenIDM failure during startup, ACTIVE_NOT_READY: Not all modules started [] [org.apache.felix.scr] []
- System changed to a not ready state:INFO: System changed to a not ready state ACTIVE_NOT_READY: Not all modules started [] [org.forgerock.openidm.scheduler] []
IDM does start successfully, as evidenced by the final line in the log (or console if you are running IDM interactively):OpenIDM ready
Recent Changes
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Causes
The ACTIVE_NOT_READY: Not all modules started
error is caused by a timeout waiting for services to start and health checks to complete. These activities are a normal part of the startup process but these errors can be seen during a slow startup. The time taken for these services to start and the health checks to complete are unique to your environment. For example, one of the health checks is a connectivity test on each connector, so the length of time needed to complete this check depends entirely on the number of connectors you have.
See Health Check Service for further information.
Solution
These messages can be safely ignored providing IDM does start (you can check your logs for the OpenIDM ready
line to confirm this).
Health check service timeout
If you want to prevent these messages being logged, you can increase the health check service timeout by adding the openidm.healthservice.servicestartmax
property to the boot.properties file (located in the /path/to/idm/resolver directory). You should specify the timeout in milliseconds; for example, with a timeout of 45 seconds:openidm.healthservice.servicestartmax=45000There isn't a recommended timeout value as this depends on your environment and size of deployment; you should test gradually increasing the timeout until you stop seeing ACTIVE_NOT_READY: Not all modules started
errors. Setting this timeout too high will not have an adverse effect such as delaying startup, but equally, you don't want it much higher than required as a genuine health check timeout won't be logged until the timeout is exceeded. See Health Check Service for further information.
See Also
Related Training
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Related Issue Tracker IDs
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