Default Configuration page shown instead of Login page in AM (All versions)
The purpose of this article is to provide assistance if the Default Configuration page is shown instead of the Login page when attempting to log into AM. The Default Configuration page is normally displayed when installing AM.
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Symptoms
When logging into AM using the usual login URL, the Default Configuration page is displayed instead of the Login page, even though AM has already been configured and previously functioned correctly.
The configuration appears to be lost.
Recent Changes
Restarted AM.
Causes
AM attempts to find its configuration when bootstrapping by looking at the path specified in the bootstrap locator file (located in the $HOME/.openamcfg/ directory of the user running the web application container).
This issue occurs when AM fails to find the configuration when bootstrapping, which can be caused by one of the following:
- Configuration store not running.
- Missing $HOME/.openamcfg/ directory; the file used to bootstrap (the bootstrap locator file) is located in this directory.
- Redeploying am.war to a different location; the bootstrap locator file is named according to where AM is deployed.
- Starting AM as a different user to the one who initially configured it; the $HOME/.openamcfg/ directory is user specific.
Solution
The solution depends on the cause; you should check the following to establish the cause and then rectify accordingly:
Configuration store
- Check that the configuration store is up and running, and that AM can successfully communicate with it:
- You can check this by running the DS status command (located in /path/to/ds/bin) or if using the embedded Configuration store (located in the /path/to/am/opends/bin directory). The server status returned to you should be: Server Run Status: Started.
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You can also send a request to the /json/health/ready endpoint (AM 7.1 and later) or the isAlive.jsp endpoint (pre-AM 7.1). If AM is running and the directory server used for the configuration store is not reachable, the endpoint will return a 503 response (AM 7.1 and later) or a Server is DOWN response (pre-AM 7.1) as described in How do I check if AM (All versions) is up and running?
$HOME/.openamcfg/ directory
- Check the $HOME/.openamcfg/ directory exists for the process owner and contains the bootstrap locator file (AMConfig). This is a file called AMConfig_[path_to_am], for example, AMConfig_opt_tomcat_webapps_am if /opt/tomcat/webapps/am is the deployment path of AM.
Deployment path
- Check that the deployment path of AM (indicated by the name of the AMConfig file) is still consistent with the path of the AM working directory. If they do not match, it could be a web container specific issue. For example, if you are using JBoss®, ensure you follow the instructions given in the AM Installation for your specific version of AM and JBoss.
Process owner
- Check the process owner; if AM is installed on a Linux® or Unix® system and is deployed on an Apache Tomcat™ web container, you can check the process owner using the following command: ps -ef |grep tomcat The process owner must be same as the user who restarted AM.
Configuration directory
- Check that the AMConfig file contains the path to a valid configuration directory, which is /path/to/am by default.
- Check the configuration directory referenced in the AMConfig file contains a file called boot.json (located in the /config sub-directory in AM 7 and later); check the contents of the boot.json file to ensure the configuration store details it contains are correct. Example configuration store details look like this: "configStoreList" : [ { "baseDN" : "dc=am,dc=forgerock,dc=org", "dirManagerDN" : "cn=Directory Manager", "ldapHost" : "localhost", "ldapPort" : 50389, "ldapProtocol" : "ldap" } ]
See Also
How do I enable message level debugging for install and upgrade issues with AM (All versions)?
Related Training
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