General

What versions of Agents are compatible with AM/OpenAM?

Last updated Sep 18, 2020

The purpose of this article is to provide compatibility information between Agents and AM/OpenAM versions. Also included is the supported Java® versions for each combination.


5 readers recommend this article

Agents and AM/OpenAM compatibility

Caution

Web policy agents 4.x and JEE policy agents 3.5.x are not supported in AM 6.5; you will need to upgrade to the latest Agents 5 release ahead of upgrading to AM 6.5. 

Web Agents

The following matrix indicates compatibility between AM/OpenAM and Web Agent versions:

  Web Agents 5.x Web Policy Agents 4.x
AM 7.x Yes (5.0.1 or later) --
AM 6.5.x Yes (5.0.1 or later) --
AM 6 Yes (5.0.1 or later) Yes *
AM 5.5.x Yes Yes
AM 5 and 5.1.x -- Yes
OpenAM 13.x -- Yes

* Restricted Tokens in AM 6.0.0.x are not compatible with older agents. It is strongly recommended to upgrade policy agents to version 5.x before upgrading to AM 6.0.0.x due to a limitation on the usage of restricted tokens with Web Agents 4.x. See OPENAM-16357 (enabling Restricted Token (com.sun.identity.enableUniqueSSOTokenCookie=true) causes error when AM checks property value) and OPENAM-16816 (Discrepancy found in AM6 + Older Agents compatibility docs.) for further details.

** New Agents Profiles on AM 6 are not compatible with Web Agents 4.x by default and will require setting the AM Login URL and AM Logout URL to work with AM 6. Additionally, the experimental REST login mode that was introduced in Web Agents 4.1.0.30 will not work with AM 6.0.0.x. See How do I configure AM 6.0.0.x to work with older policy agents (Web 4.x and JEE 3.5.x)? for details. 

Java Agents

The following matrix indicates compatibility between AM/OpenAM and Java Agent versions:

  Java Agents 5.x JEE Policy Agents 3.5.x
AM 7.x Yes (5.0.1 or later) --
AM 6.5.x Yes (5.0.1 or later) --
AM 6 Yes (5.0.1 or later) Yes *
AM 5.5.x Yes Yes
AM 5 and 5.1.x -- Yes
OpenAM 13.x -- Yes

* Restricted Tokens in AM 6.0.0.x are not compatible with older agents. It is strongly recommended to upgrade policy agents to version 5.x before upgrading to AM 6.0.0.x due to a limitation on the usage of restricted tokens with JEE Agent 3.5.x. See OPENAM-16357 (enabling Restricted Token (com.sun.identity.enableUniqueSSOTokenCookie=true) causes error when AM checks property value) and OPENAM-16816 (Discrepancy found in AM6 + Older Agents compatibility docs.) for further details.

New Agents Profiles on AM 6 are not compatible with JEE Agents 3.5.x by default and will require setting the AM Login URL and AM Logout URL to work with AM 6. See How do I configure AM 6.0.0.x to work with older policy agents (Web 4.x and JEE 3.5.x)? for details.

Note

It is strongly recommended that you always upgrade to the latest maintenance releases for the specific versions of AM/OpenAM and Agents you have deployed.

Java Compatability

Java 11

  • AM 6.5 and later.
  • Java Agents 5.6 and later.

Java 8

  • AM 5 and later; OpenAM 13.x
  • Java Agents 5.x; JEE Policy Agents 3.5

Java 7

  • AM 5.0 and 5.1.x; OpenAM 13.x
  • JEE Policy Agents 3.5

Software and Hardware requirements

AM/OpenAM

Web Agents

Java Agents

See Also

What versions of DS/OpenDJ are compatible with AM/OpenAM?

What operating systems are ForgeRock products supported on?

FAQ: Configuring Agents in AM/OpenAM

Installing and configuring AM/OpenAM

Maintenance and Patch availability policy

ForgeRock End of Service Life (EOSL) policy

Related Training

N/A

Related Issue Tracker IDs

N/A



Copyright and TrademarksCopyright © 2020 ForgeRock, all rights reserved.
Loading...