Solutions

Double-clicks on Self-Service Registration page causes duplicate entries in IDM 5.x, 6 and OpenIDM 4.x

Last updated Dec 20, 2018

The purpose of this article is to provide assistance if duplicate user entries are created in IDM/OpenIDM when a user double-clicks the Submit button on the Self-Service Registration page.


Symptoms

Issues may arise during Self-Registration when a user double-clicks the submit form. For example, a user is created multiple times in the IDM/OpenIDM database. These duplicate entries prevent the user logging in until the duplicate entry is removed.

Recent Changes

N/A

Causes

There is a known issue OPENIDM-7789 when a user double-clicks the Submit button on the Self-Service Registration page, two concurrent REST calls are sent, which creates two profiles. The profiles have unique userNames (meaning the userName uniqueness policy is still being enforced) but the presence of duplicate entries prevents a user logging in.

Solution

This issue can be resolved by updating the definition for the Submit button in the following files (located in the /path/to/idm/ui/selfservice/default/templates/user/process/registration directory):

  • userDetails-initial.html
  • kbaSecurityAnswerDefinitionStage-initial.html

You should add the ondblclick="" setting to the Submit definition so that it looks like this:

<input type="submit" class="btn btn-lg btn-primary btn-block btn-uppercase" ondblclick="" value="t 'common.form.save'" /

This change implies an empty action for double-clicks, which means the second click is ignored and only one user profile is created.

See Also

Customizing IDM/OpenIDM

Integrator's Guide › Customizing a Self-Service UI Template

Related Training

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Related Issue Tracker IDs

OPENIDM-7789 (Double click save self-registration form causes two rest calls and race condition)



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