Java Policy Agents

Requirements

ForgeRock supports customers using the versions specified here. Other versions and alternative environments might work as well. When opening a support ticket for an issue, however, make sure you can also reproduce the problem on a combination covered here.

Special requests

If you have a special request regarding support for a combination not listed here, contact ForgeRock at info@forgerock.com.

Supported Clients

Supported clients
Client Platform Native Apps(1) Chrome 62+ Edge 25+ Firefox 57+ Safari 11+ Mobile Safari

Windows 8

Windows 10

Mac OS X 10.11 or later

Ubuntu 14.04 LTS or later

iOS 9 or later

Android 6 or later

(1)Native Apps is a placeholder to indicate the platform is not limited to browser-based technologies. An example of a native app would be something written to use ForgeRock REST APIs.

AM requirements

Java Agent supports AM 6.5 and later versions.

Java Agent requires the WebSocket protocol to communicate with AM. Both the Java container and the network infrastructure must support the WebSocket protocol. For information about WebSocket support, see the documentation for you network infrastructure and Java container.

If you are upgrading from a Java Agent version before 5, note that Java Agent 5 introduced important changes in the configuration. For example, support for JAAS was dropped, and you must now enable a new property if you are not using the AM admin UI as the login page. For more information about changes introduced in Java Agent 5, refer to the Java Agent 5 Release notes.

Java Agent requires the WebSocket protocol to communicate with AM. Both the Java container and the network infrastructure must support the WebSocket protocol. For information about WebSocket support, see the documentation for your network infrastructure and Java container.

Java requirements

Java Agent runs in a Java container, and requires a Java Development Kit. ForgeRock supports customers using the following Java versions. ForgeRock recommends the most recent Java update, with the latest security fixes.

Supported versions of Java Development Kit
Vendor/version Web application containers & minimum supported versions Agent version

Oracle JDK 11, OpenJDK 11

WildFly

2023.11, 2023.9, 2023.6, 2023.3

Tomcat 9

2023.11, 2023.9, 2023.6, 2023.3

JBoss EAP 7.3+

2023.11, 2023.9, 2023.6, 2023.3

Jetty 9.4.13+(1), 10, 11

2023.11, 2023.9, 2023.6, 2023.3

Oracle JDK 17, OpenJDK 17

WildFly 25+

2023.11, 2023.9, 2023.6, 2023.3

Tomcat 9+

2023.11, 2023.9, 2023.6, 2023.3

Jetty 10+

2023.11, 2023.9, 2023.6, 2023.3

(1)Supports Java 11.

Supported versions of Java Development Kit for earlier agent versions
Vendor Version Agent version

Oracle Java

8(1), 11

5.10, 5.9

IBM Java (WebSphere only)

8

5.10, 5.9

OpenJDK

8(1), 11

5.10, 5.9

(1)Support to be discontinued in a future release.

Jakarta platform requirements

Jakarta platform requirements Java Agent 2023.11

Java Agent supports Jakarta EE 9+.

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 10(1), 10.1

  • Eclipse Jetty 11

  • WildFly Preview 24(1)(2), 25(1), 26

  • WildFly 27, 28, 29, 30

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS(1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 10(1), 10.1

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Jakarta platform requirements Java Agent 2023.9

Java Agent supports Jakarta EE 9+.

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 10(1), 10.1

  • Eclipse Jetty 11

  • WildFly Preview 24(1)(2), 25, 26

  • WildFly 27, 28

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS(1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 10(1), 10.1

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Jakarta platform requirements Java Agent 2023.6

Java Agent supports Jakarta EE 9+.

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 10(1), 10.1

  • Eclipse Jetty 11

  • WildFly Preview 24(1)(2), 25, 26

  • WildFly 27, 28

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS(1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 10(1), 10.1

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Jakarta platform requirements Java Agent 2023.3

Java Agent supports Jakarta EE 9+.

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 10(1), 10.1

  • Eclipse Jetty 11

  • WildFly Preview 24(1)(2), 25, 26

  • WildFly 27

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS(1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 10(1), 10.1

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Jakarta platform requirements Java Agent 5.10

Java Agent supports Jakarta EE 9+, with JDK 11.

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • Amazon Linux 2

  • CentOS

  • Oracle Linux

  • Red Hat Enterprise Linux

  • 7

  • 8

  • Apache Tomcat 10

  • Eclipse Jetty 11

  • WildFly Preview 24, 25, 26

  • Ubuntu Linux

  • 18.04 LTS

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2012 R2(1)

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 10

(1)Support to be discontinued in a future release.

Java EE platform requirements

Java EE platform requirements Java Agent 2023.11

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 8.5, 9.0

  • Eclipse Jetty 9.4.13 or later (1)(2), 10

  • Oracle WebLogic Server 14c (14.1.1)(2)

  • Red Hat JBoss Enterprise Application Platform 7.3(2), 7.4(2)

  • WildFly 24(1)(2), 25(1), 26

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS (1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 8.5, 9.0

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Java EE platform requirements Java Agent 2023.9

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 8.5, 9.0

  • Eclipse Jetty 9.4.13 or later (1)(2), 10

  • Oracle WebLogic Server 14c (14.1.1)(2)

  • Red Hat JBoss Enterprise Application Platform 7.3(2), 7.4(2)

  • WildFly 24(1)(2), 25, 26

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS (1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 8.5, 9.0

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Java EE platform requirements Java Agent 2023.6

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 8.5, 9.0

  • Eclipse Jetty 9.4.13 or later (1)(2), 10

  • Oracle WebLogic Server 14c (14.1.1)(2)

  • Red Hat JBoss Enterprise Application Platform 7.3(2), 7.4(2)

  • WildFly 24(1)(2), 25, 26

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS (1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 8.5, 9.0

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Java EE platform requirements Java Agent 2023.3

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • CentOS

  • 7(1)

  • Apache Tomcat 8.5, 9.0

  • Eclipse Jetty 9.4.13 or later (1)(2), 10

  • Oracle WebLogic Server 14c (14.1.1)(2)

  • Red Hat JBoss Enterprise Application Platform 7.3(2), 7.4(2)

  • WildFly 24(1)(2), 25, 26

  • Amazon Linux 2

  • Red Hat Enterprise Linux

  • Oracle Linux

  • 7(1)

  • 8

  • 9

  • Ubuntu Linux

  • 18.04 LTS(1)

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 8.5, 9.0

(1)Support to be discontinued in a future release.
(2)Does not support JDK 17.

Java EE platform requirements Java Agent 5.10

Operating systems (OS) OS versions Web application containers & minimum supported versions
  • Amazon Linux 2

  • Oracle Linux

  • Red Hat Enterprise Linux

  • 7

  • 8

  • Apache Tomcat 8.5, 9.0

  • Eclipse Jetty 9 (9.4.13 or later required for JDK 11), 10

  • IBM WebSphere Application Server 8.5(1) (8.5.5.9 or later required for Java 8), 9.0(1)

  • Oracle WebLogic Server 12c(1) (12.2.1.4 or later), 14c (14.1.1)

  • Red Hat JBoss Enterprise Application Platform 7.3, 7.4

  • WildFly 22(2), 23(2), 24, 25, 26

  • CentOS

  • 7

  • 8(2)

  • Ubuntu Linux

  • 18.04 LTS

  • 20.04 LTS

  • 22.04 LTS

  • Microsoft Windows Server

  • 2012 R2(2)

  • 2016

  • 2019

  • 2022

  • Apache Tomcat 8.5, 9.0

  • IBM AIX

  • 7

  • IBM WebSphere Application Server 8.5(1) (8.5.5.9 or later, required for Java 8), 9.0(1)

(1)Does not support JDK 11.
(2)Support to be discontinued in a future release.

Java EE platform requirements Java Agent 5.9

Operating Systems (OS) OS Versions Web Application Containers & Minimum Supported Versions
  • Amazon Linux 2

  • CentOS

  • Oracle Linux

  • Red Hat Enterprise Linux

  • 7

  • 8

  • Apache Tomcat 8.5

  • Apache Tomcat 9.0

  • Eclipse Jetty 9 (9.4.13 or later required for JDK 11)

  • Eclipse Jetty 10

  • IBM WebSphere Application Server 8.5(1) (8.5.5.9 or later required for Java 8)

  • IBM WebSphere Application Server 9.0(1)

  • Oracle WebLogic Server 12c(1) (12.2.1.4 or later)

  • Oracle WebLogic Server 14c

  • Red Hat JBoss Enterprise Application Platform 7.2(2)

  • Red Hat JBoss Enterprise Application Platform 7.3, 7.4

  • WildFly 21(2)

  • WildFly 22, 23, 24

  • Ubuntu Linux

  • 18.04 LTS

  • 20.04 LTS

  • Microsoft Windows Server

  • 2012 R2(2)

  • 2016

  • 2019

  • Apache Tomcat 8.5

  • Apache Tomcat 9.0

  • IBM AIX

  • 7

  • IBM WebSphere Application Server 8.5(1) (8.5.5.9 or later required for Java 8)

  • IBM WebSphere Application Server 9.0(1)

(1)Does not support JDK 11.
(2)Support to be discontinued in a future release.

Copyright © 2010-2023 ForgeRock, all rights reserved.