Connector Framework Changes

1.5.20.0

For a list of security issues addressed in this release, see the related Security Advisory in the ForgeRock Knowledge Base.

  • OPENICF-1566: Framework: ICF Jetty servlet default maxMessageSize is too small

1.5.19.6

No issues specific to the ICF Connector Framework were addressed in this release.

1.5.19.5

No issues specific to the ICF Connector Framework were addressed in this release.

1.5.19.4

No issues specific to the ICF Connector Framework were addressed in this release.

1.5.19.3

No issues specific to the ICF Connector Framework were addressed in this release.

1.5.19.2

No issues specific to the ICF Connector Framework were addressed in this release.

1.5.19.1

No issues specific to the ICF Connector Framework were addressed in this release.

1.5.19.0

Starting in version 1.5.19.0, ICF connectors that previously had external library dependencies now have those dependencies bundled inside the connector.

  • OPENICF-1413: Use framework version 1.5.11.0 for ldap-connector to support Java8-compatible release

  • OPENICF-1414: Scripted Groovy (v3) based connectors fail to load with IDM releases prior to 7.0

1.5.18.0

Starting in version 1.5.18.0, the ICF Connector Framework and all connectors bundled with Identity Cloud share a unified version number.

No issues specific to the ICF Connector Framework were addressed in this release.