Before You Upgrade

Fulfill these requirements before you upgrade IDM, especially before upgrading the software in a production environment. Also see the requirements listed in Before You Install and the changes listed in Incompatible Changes.

Before you start, verify that you have a supported Java version installed:

Supported Java Versions
VendorVersions

OpenJDK, including OpenJDK-based distributions:

  • AdoptOpenJDK/Eclipse Adoptium

  • Amazon Corretto

  • Azul Zulu

  • Red Hat OpenJDK

ForgeRock tests most extensively with AdoptOpenJDK/Eclipse Adoptium.

11

Oracle Java

11

If the server uses an older version that is no longer supported, install a newer Java version before you update, and follow the instructions in Check Your Java Installation.

Then, follow these steps:

  1. Back up your existing deployment by archiving the openidm directory and creating a backup of the repository and all other applicable databases.

    Note

    If you use workflow, you must manually dump the workflow database tables, and then import them before you start the new instance of IDM for the first time. The workflow database tables start with the prefix ACT_. For information on how to dump/import individual tables, see the documentation for your database.

  2. To save a record of the audit logs from your existing IDM installation, manually copy the log files from the /path/to/openidm/audit/ directory, before you start the upgrade.

  3. Download and extract IDM-7.0.2.zip from the ForgeRock BackStage download site.

Read a different version of :