Requirements

ForgeRock supports customers using the versions specified here. Other versions and alternative environments might work as well. When opening a support ticket for an issue, however, make sure you can also reproduce the problem on a combination covered here.

Supported Operating Systems & Web Application Containers

Java Agent requires the WebSocket protocol to communicate with AM. Both the Java container and the network infrastructure must support the WebSocket protocol. For information about WebSocket support, see the documentation for you network infrastructure and Java container.

Operating Systems (OS) OS Versions Web Application Containers & Minimum Supported Versions
  • Amazon Linux 2

  • CentOS

  • Oracle Linux

  • Red Hat Enterprise Linux

  • 7

  • 8

  • Apache Tomcat 8.5

  • Apache Tomcat 9.0

  • Eclipse Jetty 9 (9.4.13 or later required for JDK 11)

  • Eclipse Jetty 10

  • IBM WebSphere Application Server 8.5(1) (8.5.5.9 or later required for Java 8)

  • IBM WebSphere Application Server 9.0(1)

  • Oracle WebLogic Server 12c(1) (12.2.1.4 or later)

  • Oracle WebLogic Server 14c

  • Red Hat JBoss Enterprise Application Platform 7.2(2)

  • Red Hat JBoss Enterprise Application Platform 7.3, 7.4

  • WildFly 21(2)

  • WildFly 22, 23, 24

  • Ubuntu Linux

  • 18.04 LTS

  • 20.04 LTS

  • Microsoft Windows Server

  • 2012 R2(2)

  • 2016

  • 2019

  • Apache Tomcat 8.5

  • Apache Tomcat 9.0

  • IBM AIX

  • 7

  • IBM WebSphere Application Server 8.5(1) (8.5.5.9 or later required for Java 8)

  • IBM WebSphere Application Server 9.0(1)

(1)Does not support JDK 11.
(2)Support to be discontinued in a future release.

AM Requirements

Java Agent 5.9 supports AM 6 and later versions.

Java Agent requires the WebSocket protocol to communicate with AM. Both the Java container and the network infrastructure must support the WebSocket protocol. For information about WebSocket support, see the documentation for you network infrastructure and Java container.

If you are upgrading from a Java Agent version before 5, note that Java Agent 5 introduced important changes in the configuration. For example, support for JAAS was dropped, and you must now enable a new property if you are not using the AM console as the login page. For more information about changes introduced in Java Agent 5, refer to the Java Agent 5 Release Notes.

Java Requirements

Java Agent runs in a Java container, and requires a Java Development Kit. ForgeRock supports customers using the following Java versions. ForgeRock recommends the most recent Java update, with the latest security fixes.

Supported Java Development Kit Versions
Vendor Version

Oracle Java

8(1), 11

IBM Java (WebSphere only)

8

OpenJDK

8(1), 11

(1)Support to be discontinued in a future release.

For information about web container requirements for JDK 11, see Platform Requirements.

Supported Clients

Supported Clients
Client Platform Native Apps(1) Chrome 62+ Internet Explorer 11+(2) Edge 25+ Firefox 57+ Safari 11+ Mobile Safari

Windows 8

Windows 10

Mac OS X 10.11 or later

Ubuntu 14.04 LTS or later

iOS 9 or later

Android 6 or later

(1)Native Apps is a placeholder to indicate the platform is not limited to browser-based technologies. An example of a native app would be something written to use ForgeRock REST APIs.

(2) Support ends August 17, 2021, in alignment with the announcement from Microsoft ending support for Internet Explorer 11.

Special Requests

If you have a special request regarding support for a combination not listed here, contact ForgeRock at info@forgerock.com.